Upgrade IOS

#show version

#show file system //show the storages

#dir flash //check flash directory list

#show boot //show boot file

copy tftp flash: //will prompt some questions about tftp server IP or name

#show ip int brief vlan1 //show interface vlan1

switch(config)#boot system flash:c2960-lanlitek9-mz.150-2,SE5.bin //boot from a specific IOS file

#reload

Backup startup configuration:
#copy startup-config flash:
#Destination filename [startup-config]?

Restore
copy flash:backupconfig running-config

Configure VLAN – Single and Multiple

Create a VLAN
#configure terminal
(config)#vlan 10
(config-vlan)#name management

Add a port to vlan
Switch(config)# interface fastEthernet 0/2 (or a range: interface range fa0/2 - 10)
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10

Turn on vlan
switch(config)#interface vlan 10

Verify
Switch#show vlan id 10 (or show vlan name management)

Configure DHCP
Router#conf terminal
Router(config)#service dhcp
Router(config)#ip dhcp excluded-address 192.168.3.1 192.168.3.10
Router(config)#ip dhcp pool vlan10
Router(dhcp-config)#network 192.168.3.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.3.1
Router(dhcp-config)#dns-server
Router(dhcp-config)#dns-server 8.8.8.8

Set up DHCP for multiple VLANs

Notes
# Interface fa0/1
# switchport trunk
# switchport trunk vlan 50 ("swtichport natvie vlan 50" does not work)

1. Set up Router
router(config)#int fa 0/0 (turn the port on)

router(config)#int fa 0/0.10
router(config-if)#encapsulation dot1q 10 (vlan 10)
router(config-if)#ip address 192.168.10.1 255.255.255.0

router(config)#int fa 0/0.15
router(config-if)#encapsulation dot1q 15 (vlan 15)
router(config-if)#ip address 192.168.15.1 255.255.255.0

router(config)#int fa 0/0.80
router(config-if)#encapsulation dot1q 80 native (vlan 80)
router(config-if)#ip address 192.168.80.1 255.255.255.0

router(config)#int fa 0/0.99 (management vlan)
router(config-if)#encapsulation dot1q 99 native (vlan 99)
router(config-if)#ip address 192.168.99.1 255.255.255.0

2. Set up vlan in the switch
switch#(config)#int fa 0/1
switch#(config-if)switchport turnk native vlan 80 (mutliple vlans to go through)

switch#(config)#int vlan 99 (management vlan)
switch#(config-if)#ip address 192.168.99.2 255.255.255.0

switch#(config)#ip default-gateway 192.168.99.1 255.255.255.0
switch#(config)#int range fa 0/10 - fa 0/14
switch#(config-if)#spanning-tree portfast (so they will receive ip addresses faster)
switch#(config-if)#switchport mode access
switch#(config-if)#switchport access vlan 10

switch#(config)#int range fa 0/15 - fa 0/19
switch#(config-if)#spanning-tree portfast (so they will receive ip addresses faster)
switch#(config-if)#switchport mode access
switch#(config-if)#switchport access vlan 15


3. Set up DHCP in the router

router(config)#ip dhcp pool first-floor
router(dhcp-config)#network 192.168.10.0 255.255.255.0
router(dhcp-config)#default-router 192.168.10.1

router(config)#ip dhcp pool second-floor
router(dhcp-config)#network 192.168.15.0 255.255.255.0
router(dhcp-config)#default-router 192.168.15.1

Cisco 2960

Restore Err-disabled Port
SW02#config terminal
SW02(config)#interface gigabitEthernet 1/0/24
SW02(config-if)#shut
SW02(config-if)#no shut

Enable SSh:
https://www.cisco.com/c/en/us/support/docs/security-vpn/secure-shell-ssh/4145-ssh.html
https://www.grandmetric.com/knowledge-base/design_and_configure/how-to-enable-ssh-on-cisco-device/

!--- Step 1: Configure the hostname if you have not previously done so.

hostname carter

!--- The aaa new-model command causes the local username and password on the router

!--- to be used in the absence of other AAA statements.

aaa new-model

username cisco password 0 cisco

Password types: https://www.router-switch.com/faq/six-types-of-cisco-password.html

!--- Step 2: Configure the DNS domain of the router.

ip domain-name rtp.cisco.com

!--- Step 3: Generate an SSH key to be used with SSH.

crypto key generate rsa

ip ssh time-out 60

ip ssh authentication-retries 2

!--- Step 4: By default the vtys' transport is Telnet. In this case,

!--- Telnet is disabled and only SSH is supported.

line vty 0 4

transport input SSH

Edit: you also need to assign an ip address to vlan (your management vlan) so you can remote in using putty or something.

Updated Information
https://networklessons.com/cisco/ccna-200-301/configure-ssh-cisco-ios
https://www.cisco.com/en/US/docs/switches/lan/catalyst3850/software/release/3.2_0_se/multibook/configuration_guide/b_consolidated_config_guide_3850_chapter_0110010.html

Cisco – Switches Notes